[gilug] Re: urlparse y python3 (fancy UOC)

Narcis Garcia informatica actiu net
2016-11-26 09:39:49 UTC


La UOC, com és el seu hàbit, no reconeix la compatibitat amb GNU/Linux a
la seva pàgina. Seguint al «Securew2» es veu que si.
Teniu en compte que l'eina que us fa descarregar és programari privatiu.

Ara ho he provat en una màquina virtual d'Ubuntu Gnome 16.04 (Live), i
només m'ha fet falta instal·lar el paquet python-dbus, ja que a mi només
se'm queixava de no trobar «dbus».
Com que python-dbus3 ja estava instal·lat, sospito que el programet
aquest deu dependre de components de la versió 2 de Python, que potser
siguin els paquets que no porten un «3» al final.

Et recomano que tu també facis les proves en el mateix escenari abans de
dir-li el que ha de fer, així tot li sortirà més a la primera.


El 26/11/16 a les 01:52, Nuei ha escrit:
> Bones.
> 
> Tinc un colega que s'està pasant a ubuntu per primer cop i li he dit que
> em pregunti el que necessiti perquè sinó al principi ho tindrà una mica
> fotut. Està motivat i ja s'ha trobat un primer problema.
> 
> S'ha posat Ubuntu amb Gnome.
> 
> Necessita executar aquest programa:
> http://www.uoc.edu/portal/ca/universitat/contacte-seus/eduroam/index.html
> 
> Quan el descarrega fot la comanda:
> $ python3 SecureW2_JoinNow.py
> Error: One or more required python libraries have not been installed: No
> module named 'urlparse'
> 
> Busco a apt:
> $ apt-cache search urlparse
> python-uritools - RFC 3986 compliant replacement for urlparse (Python 2)
> python3-uritools - RFC 3986 compliant replacement for urlparse (Python 3)
> 
> Instal·la el de python3.
> 
> No funciona, mateix missatge quan intenta executar el SecureW2_JoinNow.py
> 
> Busco a PIP:
> 
> $ pip3 search urlparse
> uritools                  - RFC 3986 compliant, Unicode-aware,
> scheme-agnostic replacement for urlparse
>   INSTALLED: 1.0.1
>   LATEST:    2.0.0
> urlparse4                 - Performance-focused replacement for Python's
> urlparse module
> urlparse3                 - urlparse3 is simple and powerful url parsing
> tool
>   INSTALLED: 1.0.10 (latest)
> urlparse2                 - urlparse for humans.
> giturlparse.py            - A Git URL parsing module (supports parsing
> and rewriting)
> murl                      - murl is a tiny wrapper for the Python module
> urlparse.
> 
> Instal·la:
> $ pip3 install urlparse3
> 
> Un altre cop, no funciona.
> 
> 
> M'he posat en:
> https://pypi.python.org/pypi/urlparse3/1.0.10
> 
> Però aquí ja em perdo. Algú em pot donar un cop de mà per aconsellar-li?
> Aitor
> 
> ________________________________________________________
> LLISTA DE DISTRIBUCIO DE CORREU del GiLUG
> --------------------------------------------------------
> - Per a escriure a tothom de la llista, envia el teu missatge a: usuaris(arrova)llista.gilug.org
> - Per a d'altres questions sobre la llista o subscripcio, autogestiona't a:
> http://llista.gilug.org/mailman/listinfo/usuaris
> * Tots els missatges queden publicats a:
> http://llista.gilug.org/pipermail/usuaris/
> 




More information about the gilug mailing list