[gilug.org] Novato busca lider Debian

Jordi Pujol jordipujol arsystel com
2004-11-18 21:59:38 UTC


Hola,

Per lo que dius de que modificant el sources.list tambe funciona, 
ara no podem canviar woody per sarge o per sid ja que els nous origens no ens 
ho posen aixo, ( si canviem woody per sarge canviarem nomes unes poques 
linies antigues que corresponen a algun origen de paquets complementaris, i 
despres farem l'actualitzacio i estarem passant el sistema a testing, per 
defecte ).
Tambe hem de considerar que stable, testing i unstable son llocs de pas, en 
principi els paquets començen en unstable per passar a testing, i despres a 
stable, pero al passar al lloc seguent ja els treuen dels llocs anteriors, 
per lo que hem de tenir la visio complerta del conjunt per tal de buscar en 
tots ells la ultima versio dels nostres paquets.

Jo deia de no fer el dist-upgrade abans de haver completat els altres dos per 
certs comentaris que he vist, per exemple al sources.list que va a la Knoppix 
3.6 diu:

" # If you want to do a "full upgrade", you should first
  # upgrade the Packages from Debian/unstable (KDE & Co.)
  # before doing a (dist-)upgrade for Debian/testing. "

que, miranm'ho be ara no ho interpreto aixi, sino que veig que es refereix a 
algun problema amb el KDE. ( Pero jo no ho faig pas aixo de posar el KDE a 
unstable, es mes he comprovat que tambe hi trobem actualitzacions del KDE en 
testing )

Per lo que fa als paquets actualitzats, els kernels no tenen noves versions 
sino que cada revisio es un paquet amb nom diferent, per lo que no ens 
actualitzara un kernel, l'hem de instalar expressament. Lo que no se es si el 
dist-upgrade ens posa un nou kernel, va aixi ?

Ara mirare com s'envien articles a la Web, i fare un resum,

Salut,

Jordi Pujol



El Jueves, 18 de Noviembre de 2004 10:04, Oriol Pellicer i Sabrià escribió:
> A Dimarts 16 Novembre 2004 18:04, Jordi Pujol va escriure:
> > Hola,
>
> Bones!
>
> > Perdoneu, pero la idea que tinc jo es diferent, en la meva distribucio ja
> > no posa woody o sarge, (que existien en la versio 3.0 pero varen ser
> > canviats des de la versio 3.1) sino stable, testing i unstable, i el
> > procediment d'actualitzacio es el següent:
> > segons el manual de l'apt-get no s'ha de modificar el sources.list sino
> > fer un fitxer anomenat /etc/apt/preferences, que dona un pes relatiu a
> > cada un dels nivells als que volem actualitzar.
> > De manera que en el sources.list podem posar tant els origens de les
> > distribucions stable, test, com unstable i tambe altres origens que tenen
> > paquets complementaris, el fitxer preferences ens diu de quines
> > actualitzar.
> >
> > per exemple, aquest es el meu preferences, que estableix actualitzar el
> > sistema a nivell testing:
> >
> > Package: *
> > Pin: release o=Debian,a=stable
> > Pin-Priority: 900
> >
> > Package: *
> > Pin: release o=Debian,a=testing
> > Pin-Priority: 111
> >
> > Package: *
> > Pin: release o=Debian,a=unstable
> > Pin-Priority: 10
> >
> > Package: *
> > Pin: release o=Debian
> > Pin-Priority: -1
> >
> > per definicio interna del programa, amb "apt-get" agafem automaticament
> > des de les fonts que tenen una prioritat mes gran de 100, i de les altres
> > nomes quan seleccionem expressament un paquet. Tambe hem de considerar
> > que si no hi ha fitxer preferences la actualizacio es fa a nivell
> > testing.
>
> Carai, sort que hi ha gent que es mira els manuals :-P. No m'havia ni
> assabentat que existís, això del preferences...  Per cert, que potser
> podries enviar una mica de resum (bàsicament això del mail) a la web per
> tal que tothom ho pugui tenir a mà i tal O:-)
> De tota manera, modificant el sources.list també funciona, encara que
> segons el que dius potser no és "com toca"(tm). Però en el cas de l'Agus,
> potser és més senzill fer els canvis al sources.list i apt-get update &&
> apt-get dist-upgrade -y com deia l'Eduard. Això del "preferences" no seria
> més per màquines on tens versions barrejades?
>
> > Respecte a les ordres d'actualitzacio, hem de fer tres ordres per
> > actualitzar el nostre sistema a la ultima, i per aquest ordre
> >
> > apt-get update   # agafa les llistes dels ultims paquets disponibles en
> > cada lloc
> >
> > apt-get upgrade   # fa la actualitzacio del sistema operatiu
> >
> > apt-get dist-upgrade   # fa la actualitzacio de la distribucio
> >
> > sobretot, no hem de fer el dist-upgrade abans de completar correctament
> > les altres dues.
> > es preferible fer-les per separat per poder solucionar els problemes que
> > poden sortir en cada un d'ells
>
> Això dels apt-get ja no ho veig tant clar:
> - apt-get update actualitza la llista de paquets, això és imprescindible
> abans de qualsevol altra cosa.
> - apt-get upgrade actualitza tots els paquets del sistema però mantenint la
> versió, és a dir si tenim el kernel 2.6.7 i ja ha sortit el 2.6.8, amb
> l'upgrade no s'actualitzarà, només posarà la darrera versió del 2.6.7, per
> exemple (si existís) la 2.6.7-2-686.
> - apt-get dist-upgrade actualitza tot el sistema al màxim, canviant les
> versions dels paquets i tot, en l'exemple anterior instal·laria el kernel
> 2.6.8-1-686. En la versió "unstable" sempre s'ha de fer aquest, és el més
> lògic, ja que les versions canvien ràpidament. De tota manera, per fer un
> dist-upgrade no és necessari fer abans un upgrade.
>
>
> salut!



More information about the gilug mailing list